验证中...
vue中的部分es6的语法不兼容
Raw Copy
vue在IOS9中不生效。S6 不能完全的呗浏览器兼用,所以我们可能需要转化成 ES5
问题:ios9无法识别es6语法
解决方法:将es6转换成es5
具体流程:
1:进入项目
2:找到要转换的js文件。(如果是在<script>标签中写的,要抽离出来,否则无法转换)
3:Babel的安装:---------------------------------------------------------------:npm install -g babel-cli // -g 表示全局安装到 nodejs 下的目录
4:将 Babel 的转换插件安装到项目的目录中:-------------------------------------:npm install babel-preset-es2015 --save
5:执行手动转换命令:----------------------------------------------------------:babel es6.js(要转换的) --out-file es5.js(转换后) --presets es2015
6: 引用转换后的js.
7:OK,完美解决。
优化:
如果我们每次修改代码都手动转换太过麻烦,加个自动监听的参数:-w-----------------:babel es6.js -w --out-file es5.js --presets es2015
其他解决方案:
也可以在浏览器端实时转换es6转换为es5:
1:下载转换组件库到项目的目录下:------------------------------------------------: npm install babel-core@5 --save
// 引入es6的代码 text/babel
<script type="text/babel" src="es6.js"></script>
<!-- 网页端实时转换 -->
<script type="text/javascript" src="node_modules/babel-core/browser.min.js"></script>
利用 browser-sync 实现实时刷新静态页面:
2:npm install -g browser-sync
// 启动3000端口,监听项目下的所有文件
browser-sync start --server --files "**"。

Comment list( 0 )

You need to Sign in for post a comment

Help Search

183227_9af5e6a8_1826025 111910_4d91f001_1826025