21 Star 118 Fork 21

rachpt / lanzou-gui

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
克隆/下载
build_app.spec 1.44 KB
一键复制 编辑 原始数据 按行查看 历史
rachpt 提交于 2021-05-16 01:03 . v0.4.0
# -*- mode: python ; coding: utf-8 -*-
# 本文件用于打包 MacOS 应用
# pyinstaller --clean --noconfirm build_app.spec
version = '0.4.0'
block_cipher = None
a = Analysis(['main.py'],
pathex=['.'],
binaries=[],
datas=[],
hiddenimports=[],
hookspath=[],
runtime_hooks=[],
excludes=['./lanzou/gui/login_assister.py', ],
win_no_prefer_redirects=False,
win_private_assemblies=False,
cipher=block_cipher,
noarchive=False)
pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
exe = EXE(pyz,
a.scripts,
a.binaries,
a.zipfiles,
a.datas,
[],
name='lanzou-gui',
debug=False,
bootloader_ignore_signals=False,
strip=False,
upx=True,
upx_exclude=[],
runtime_tmpdir=None,
console=False ,
icon='app_icon.icns')
app = BUNDLE(exe,
name='lanzou-gui.app',
icon='./app_icon.icns',
info_plist={
'CFBundleDevelopmentRegion': 'Chinese',
'CFBundleIdentifier': "cn.rachpt.lanzou-gui",
'CFBundleVersion': version,
'CFBundleShortVersionString': version,
'NSHumanReadableCopyright': u"Copyright © 2021, rachpt, All Rights Reserved"
},
bundle_identifier=None)
Python
1
https://gitee.com/rachpt/lanzou-gui.git
git@gitee.com:rachpt/lanzou-gui.git
rachpt
lanzou-gui
lanzou-gui
master

搜索帮助