10 Star 0 Fork 4

src-openEuler / curvesapi

Create your Gitee Account
Explore and code with more than 8 million developers,Free private repositories !:)
Sign up
This repository doesn't specify license. Please pay attention to the specific project description and its upstream code dependency when using it.
Clone or Download
curvesapi.spec 1.33 KB
Copy Edit Web IDE Raw Blame History
雷炬 authored 2020-08-18 16:56 . Package init
%global githash 25f63a4a5a98a4bc82bb0e155cdf4d28e0c9e8a7
Name: curvesapi
Version: 1.04
Release: 1
Summary: Java implementation of various mathematical curves
License: BSD
URL: https://github.com/virtuald/curvesapi
Source0: https://github.com/virtuald/curvesapi/archive/%{githash}/%{name}-%{version}.tar.gz
BuildRequires: maven-local mvn(junit:junit)
BuildArch: noarch
%description
Implementation of various mathematical curves that define themselves
over a set of control points. The API is written in Java. The curves
supported are: Bezier, B-Spline, Cardinal Spline, Catmull-Rom Spline,
Lagrange, Natural Cubic Spline, and NURBS.
%package javadoc
Summary: Javadoc for %{name}
%description javadoc
This package contains javadoc for %{name}.
%prep
%setup -q -n %{name}-%{githash}
for file in r*.txt demo/*.java
do
sed -i.orig 's|\r||g' $file
touch -r $file.orig $file
rm $file.orig
done
%mvn_file :%{name} %{name}
%build
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
%install
%mvn_install
%files -f .mfiles
%doc README.md readme.txt release-notes.txt scshot.png demo
%license license.txt
%files javadoc -f .mfiles-javadoc
%license license.txt
%changelog
* Fri Aug 14 2020 leiju <leiju4@huawei.com> - 1.04-1
- Package init
1
https://gitee.com/src-openeuler/curvesapi.git
git@gitee.com:src-openeuler/curvesapi.git
src-openeuler
curvesapi
curvesapi
openEuler-22.03-LTS

Search