5 Star 0 Fork 5

src-openEuler / python-QtPy

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-qtpy.spec 3.35 KB
一键复制 编辑 原始数据 按行查看 历史
jiangxinyu 提交于 2023-11-06 10:35 . Update package to version 2.4.1
%global _empty_manifest_terminate_build 0
Name: python-QtPy
Version: 2.4.1
Release: 1
Summary: Provides an abstraction layer on top of the various Qt bindings
License: MIT and BSD
URL: https://github.com/spyder-ide/qtpy
Source0: https://files.pythonhosted.org/packages/eb/9a/7ce646daefb2f85bf5b9c8ac461508b58fa5dcad6d40db476187fafd0148/QtPy-2.4.1.tar.gz
BuildArch: noarch
%description
QtPy (pronounced ‘cutie pie’) is a small abstraction layer that lets you
write applications using a single API call to either PyQt or PySide.
It provides support for PyQt5, PyQt4 and PySide using the PyQt5 layout
(where the QtGui module has been split into QtGui and QtWidgets).
Basically, you write your code as if you were using PyQt5 but import qt from
qtpy instead of PyQt5.
%package -n python3-QtPy
Summary: Provides an abstraction layer on top of the various Qt bindings
Provides: python-QtPy = %{version}-%{release}
BuildRequires: python3-setuptools
BuildRequires: python3-devel
%description -n python3-QtPy
QtPy (pronounced ‘cutie pie’) is a small abstraction layer that lets you
write applications using a single API call to either PyQt or PySide.
It provides support for PyQt5, PyQt4 and PySide using the PyQt5 layout
(where the QtGui module has been split into QtGui and QtWidgets).
Basically, you write your code as if you were using PyQt5 but import qt from
qtpy instead of PyQt5.
%package help
Summary: Development documents and examples for QtPy
Provides: python3-QtPy-doc
%description help
QtPy (pronounced ‘cutie pie’) is a small abstraction layer that lets you
write applications using a single API call to either PyQt or PySide.
It provides support for PyQt5, PyQt4 and PySide using the PyQt5 layout
(where the QtGui module has been split into QtGui and QtWidgets).
Basically, you write your code as if you were using PyQt5 but import qt from
qtpy instead of PyQt5.
%prep
%autosetup -n QtPy-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-QtPy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Nov 06 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 2.4.1-1
- Update package to version 2.4.1
* Tue Apr 4 2023 wubijie <wubijie@kylinos.cn> - 2.3.1-1
- Update package to version 2.3.1
* Thu Nov 10 2022 wangjunqi <wangjunqi@kylinos.cn> - 2.3.0-1
- Update package to version 2.3.0
* Mon Aug 01 2022 liukuo <liukuo@kylinos.cn> - 2.1.0-1
- Update to 2.1.0
* Tue Jun 29 2021 Lianguo Wang <wanglianguo> - 1.9.0
- Initial package for openEuler, QtPy version 1.9.0.
1
https://gitee.com/src-openeuler/python-QtPy.git
git@gitee.com:src-openeuler/python-QtPy.git
src-openeuler
python-QtPy
python-QtPy
master

搜索帮助