32 Star 164 Fork 22

铜豌豆 Linux / debian-cn

 / 详情

新软件包集成需求

Backlog
owner
Opened this issue  
2019-10-18 17:24

铜豌豆对新增软件包持开放态度,各类自由软件和商业软件均欢迎。

软件包需要满足的基本要求如下:

https://www.atzlinux.com/allpackages.htm#pkgrules

大家对《铜豌豆》项目的新软件包需求,可以按下面的模板提需求哈。

软件包名称

软件包用途

软件包主页地址、下载地址

版权协议

如果是商业软件,麻烦尽可能的确认下使用范围。是可以免费商用,还是只允许个人使用?

商业软件和开源软件都可以接受。只要目前 Debian 官方没有集成的 Linux 桌面软件均可。

麻烦在把上述内容拷贝,在 Issue 里面, 新建一个 “新软件包集成需求:【软件包名】” Issue 。

Comments (43)

atzlinux created任务
atzlinux set assignee to atzlinux
atzlinux set deadline to 2019-10-19
atzlinux set start time to 2019-10-18
atzlinux changed deadline from 2019-10-19 to 2030-12-31
atzlinux set top level to Medium
atzlinux set branch to apt-install
atzlinux set priority to P3
atzlinux added
 
enhancement
label
atzlinux changed issue state from 待办的 to 进行中
Expand operation logs

请问atzlinux 提供的buster镜像是用什么方法更新内容的?apt.atzlinux.com 好像没有开放访问目录?

atzlinux changed issue state from 进行中 to 待办的

软件包名称:slack-desktop
软件包用途:办工聊天客户端,使用案例: wuhan2020
下载地址:https://slack.com/ 有官方打包的 deb 包 (beta-version)

@free_wind 这个软件中文界面还不太友好,考虑到 wuhan2020项目在用,还是加到了软件源里面,请使用下面的命令安装:
apt -y install slack-desktop

atzlinux changed description
atzlinux changed description
atzlinux changed description
atzlinux changed top level from Medium to High

@atzlinux 已看到issue,请先安装v2ray-core

v2raya安装完毕是没有快捷方式的,如果你需要创建一个快捷方式,可以参考

[Desktop Entry]
Version=1.0
Terminal=false
Type=Application
Name=#test
Exec=python -m webbrowser "https://v2raya.mzz.pub"
Icon=#icon

后缀为.desktop

atzlinux changed description

@mzz2017 ,可以把这个文件放到 deb 包里面哈

@atzlinux dpkg -L slackdesktop 显示有 /usr/lib/slack/locales/zh-CN.pak

另外可以更新下软件包,官网有新版

软件源能否添加到deepin中

@lemon 可以的添加的。

@free_wind 软件源升级到最新的 4.3.2。

应该是 /usr/lib/slack/locales/zh-CN.pak 这个文件里面,中文翻译不完全,导致界面看起来大部分还是英文。

atzlinux changed description
atzlinux changed description

@free_wind 软件源升级到最新的 4.3.2。
应该是 /usr/lib/slack/locales/zh-CN.pak 这个文件里面,中文翻译不完全,导致界面看起来大部分还是英文。

@atzlinux Yes

软件包名称:honkai-import-background
软件包用途:壁纸
软件包主页地址、下载地址:https://gitee.com/PokerFace128/K423_Lab_Soft/releases/Soft
版权协议:仅供个人使用

@PokerFace 已经收录的铜豌豆软件源,谢谢!

软件包名称:Spark Store
软件包用途:应用商店 由deepin社区各位大佬维护 软件包安装在/opt/durapps(该规格是由统信的Deepin社区发布)
软件包主页地址、下载地址:https://spark-app.store
版权协议 未知 但该项目有gitee

备注:若要收录,可选择收录该应用商店或者直接套我们的商店源
战绩:已被 OBSProject 点名表扬并在安装手册内提供该应用的安装方式来安装 OBS Studio

软件包名称:Spark Store
从该地址下载软件包后:
https://dcstore.spark-app.store/store/tools/spark-store/spark-store_2.0.2.3_amd64.deb

sha1sum spark-store_2.0.2.3_amd64.deb
21ec1619ea0cbe62de3aa7bbee13989f8863d7eb  spark-store_2.0.2.3_amd64.deb
lintian spark-store_2.0.2.3_amd64.deb
warning: tainted binary package 'spark-store', skipping

Debian 的 lintian 质量检查工具报错。

在铜豌豆 10.6.1 下安装,会提示缺少依赖包。
把相关依赖包安装上后,程序启动报 段错误。

看能否提供一个可以在 Debian 10 上的软件包?

@八蓝米科技丶以勒

@atzlinux https://dcstore.spark-app.store/spark-store-dependencies-kylin.zip
这是其他发行版所需要的补丁 可以试试看先装补丁再装商店

@atzlinux https://dcstore.spark-app.store/spark-store-dependencies-kylin.zip
这是其他发行版所需要的补丁 可以试试看先装补丁再装商店

@八蓝米科技丶以勒 ,安装了这些软件包,还是不行,程序还是无法启动。

@atzlinux
添加源 deb [by-hash=force] https://store.jerrywang.top
指令
apt install spark-store

对了 作者shenmo 提到了2.0.2.3有一个奇怪的bug 会调用gui widget core这三者都没有的东西 目前正在排查和修复
可以先从源开始使用下载商店内收录的应用看看
或者可以从源内找到spark-store=1.0-beta7.2

软件包名称:variety
软件包用途:壁纸管理器
软件包主页:https://peterlevi.com/variety/
源码地址:https://github.com/varietywalls/variety
版权协议:GPL-3.0 License

@rust8 variety 这个软件包,Debian 官方软件包里面已经有了,可以直接安装的。

@rust8 variety 这个软件包,Debian 官方软件包里面已经有了,可以直接安装的。

@atzlinux 好的 :ok_hand:

软件包名称:sunloginclient
软件包用途:远程主机控制
软件包主页:https://sunlogin.oray.com/download/
源码地址:not appliable
版权协议:not appliable

软件包名称:sunloginclient
软件包用途:远程主机控制
软件包主页:https://sunlogin.oray.com/download/
源码地址:not appliable
版权协议:not appliable

@free_wind

sunloginclientshell-10.1.1.28779-amd64.deb 这个命令行客户端软件包,安装时报错:

正在设置 sunloginclient (10.1.1.28779) ...
Error:unknown OS it not impl
Installation failed
dpkg: 处理软件包 sunloginclient (--configure)时出错:
已安装 sunloginclient 软件包 post-installation 脚本 子进程返回错误状态 1
正在处理用于 desktop-file-utils (0.23-4) 的触发器 ...
正在处理用于 libc-bin (2.28-10) 的触发器 ...
正在处理用于 mailcap (3.68) 的触发器 ...
在处理时有错误发生:
sunloginclient
E: Sub-process /usr/bin/dpkg returned an error code (1)

看了下其包的脚本,是专门检测了操作系统版本,默认不支持 Debian,需要重新打包才能够支持。

软件包名称:sunloginclient
软件包用途:远程主机控制
软件包主页:https://sunlogin.oray.com/download/
源码地址:not appliable
版权协议:not appliable

@free_wind SunloginClient-10.1.1.38139_amd64.deb,其图形版本,依赖了一个在 Debian 中不存在的软件包:libwebkitgtk-3.0-0 ,无法安装。

打包请求: deskreen
连接:https://github.com/pavlobu/deskreen
描述:桌面共享程序

打包请求: deskreen
连接:https://github.com/pavlobu/deskreen
描述:桌面共享程序

@taotieren

铜豌豆软件源 https://www.atzlinux.com/allpackages.htm
软件动态:

2021-02-22
    增加 deskreen 屏幕共享软件

打包请求:OpenCC
上游:https://github.com/BYVoid/OpenCC
描述:

中文简繁转换开源项目,支持词汇级别的转换、异体字转换和地区习惯用词转换(中国大陆、台湾、香港、日本新字体)。不提供普通话与粤语的转换

Debian 官方软件包,已经有这个包。铜豌豆 iso 也已经集成。

打包请求:OpenCC
上游:https://github.com/BYVoid/OpenCC
描述:
中文简繁转换开源项目,支持词汇级别的转换、异体字转换和地区习惯用词转换(中国大陆、台湾、香港、日本新字体)。不提供普通话与粤语的转换

@taotieren opencc 软件包,Debian 官方已经有的。
铜豌豆 iso 也已经默认安装了这个软件包。

打包请求:Joplin
上游:https://github.com/laurent22/joplin
描述:
这是一个笔记软件,还带待办事项清单功能,可处理markdown笔记文件,再依照标签进行分类。提供端对端加密,可通过 Nextcloud、Dropbox 等云端服务行同步。最大程度尊重用户隐私。

这个软件包,有中文界面了吗?目前在铜豌豆上,是否可以正常安装运行?

也可以尝试给上游提一个制作 deb 包的需求,看他们项目是否愿意做?

wine-appimage

AppImage 是一种把应用打包成单一文件的格式,允许在各种不同的目标系统(基础系统(Debian、RHEL等),发行版(Ubuntu、Deepin等))上运行,无需进一步修改。 创建Appimage就是搜集可执行程序及其依赖,放到一个文件夹下面。然后设置可执行文件依赖库路径,使得程序的执行不再依赖当前系统环境。此文件夹就相当于程序执行时的系统环境,然后将文件夹压缩,最后打包成Appimage。 运行Appimage时会解压出文件夹,然后运行其中的可执行脚本。

sudo ln -s $(pwd)/Wine-x86_64.AppImage /usr/bin/wine

https://github.com/Hackerl/Wine_Appimage

请问有 deb 的安装包吗?在铜豌豆测试情况如何?

打包需求

软件包名称

nwjs

软件包用途

nwjs是一个基于 Chromium 的 node.js 运行环境,可以作为本地的客户端软件的基本进程。开发者可以通过 html 和 javascript css 等web前端技术以及 nodejs 等技术将应用程序写好,然后通过 nwjs 来在本地运行,并且成为不同的软件运行实例。

软件包主页地址、下载地址

https://nwjs.io/
https://github.com/nwjs/nw.js

国内相关页面

http://npm.taobao.org/mirrors/nwjs/
https://nwjs.org.cn/

版权协议

MIT License (他们的github页面的显示)


补充信息:Chromium 是 google 公司主导的开源项目,nwjs则最早似乎是intel公司的团队牵头做的

建议打包最新版和稳定版本即可,如果只维护一个,不必打包最新版本,维护一个稳定版本即可。

要链接可执行文件 nw 到 /usr/bin


好像debian并没有相关的包,但有 npm (nodejs的包管理软件)。

这个包不打也行,但打了感觉可以配合一些自动化工具。

可以尝试自己打好 deb 包,提交到铜豌豆软件源。或者给开源社区上游提打包需求的 issue。

好像上游根本没社区……。。。

妙有画板已经发展到0.0.10版,扩充了很多功能,提升了用户体验,请求版本更新,项目主页https://gitee.com/xxmw/mydraw 。二进制安装包是基于debian11制作的,如果需要基于debian10的安装包,请通知我重新打包。

在 Debian 10 下,有依赖问题,麻烦重新在 Debian 10 下打包,谢谢!

下列软件包有未满足的依赖关系:
mydraw : 依赖: gambas3-runtime (>= 3.15) 但是 3.12.2-1 正要被安装
依赖: gambas3-gb-form (>= 3.15) 但是 3.12.2-1 正要被安装
依赖: gambas3-gb-form-dialog (>= 3.15) 但是 3.12.2-1 正要被安装
依赖: gambas3-gb-image (>= 3.15) 但是 3.12.2-1 正要被安装
依赖: gambas3-gb-image-imlib (>= 3.15) 但是 3.12.2-1 正要被安装
依赖: gambas3-gb-qt5 (>= 3.15) 但是 3.12.2-1 正要被安装
依赖: gambas3-gb-settings (>= 3.15) 但是 3.12.2-1 正要被安装

atzlinux changed description

Sign in to comment

Status
Assignees
Milestones
Pull Requests
Successfully merging a pull request will close this issue.
Branches
Planed to start   -   Planed to end
-
Top level
Priority
参与者(10)
5349448 atzlinux 1586501537 5260206 bmi yile 1578983381 7783107 rust8 1609394091 672838 taotieren 1578930501 8016794 he15810197483 1622681909 8237170 xxmw 1604392674
Shell
1
https://gitee.com/atzlinux/debian-cn.git
git@gitee.com:atzlinux/debian-cn.git
atzlinux
debian-cn
debian-cn

Search

184635 d8eb8a04 1850385 161156 f1cf3f24 1850385