1 Star 0 Fork 0

hornsey / substrate-node-demo

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
克隆/下载
shell.nix 1.14 KB
一键复制 编辑 原始数据 按行查看 历史
Dan Shields 提交于 2021-10-04 06:02 . Update shell.nix (#247)
let
mozillaOverlay =
import (builtins.fetchGit {
url = "https://github.com/mozilla/nixpkgs-mozilla.git";
rev = "57c8084c7ef41366993909c20491e359bbb90f54";
});
pinned = builtins.fetchGit {
# Descriptive name to make the store path easier to identify
url = "https://github.com/nixos/nixpkgs/";
# Commit hash for nixos-unstable as of 2020-04-26
# `git ls-remote https://github.com/nixos/nixpkgs nixos-unstable`
ref = "refs/heads/nixos-unstable";
rev = "1fe6ed37fd9beb92afe90671c0c2a662a03463dd";
};
nixpkgs = import pinned { overlays = [ mozillaOverlay ]; };
toolchain = with nixpkgs; (rustChannelOf { date = "2021-09-14"; channel = "nightly"; });
rust-wasm = toolchain.rust.override {
targets = [ "wasm32-unknown-unknown" ];
};
in
with nixpkgs; pkgs.mkShell {
buildInputs = [
clang
pkg-config
rust-wasm
] ++ stdenv.lib.optionals stdenv.isDarwin [
darwin.apple_sdk.frameworks.Security
];
LIBCLANG_PATH = "${llvmPackages.libclang}/lib";
PROTOC = "${protobuf}/bin/protoc";
RUST_SRC_PATH = "${toolchain.rust-src}/lib/rustlib/src/rust/library/";
ROCKSDB_LIB_DIR = "${rocksdb}/lib";
}
1
https://gitee.com/hornsey/substrate-node-demo.git
git@gitee.com:hornsey/substrate-node-demo.git
hornsey
substrate-node-demo
substrate-node-demo
dev_task

搜索帮助