3 Star 0 Fork 0

src-oepkgs / lua-fun

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
lua-fun-0.1.3.spec 2.14 KB
一键复制 编辑 原始数据 按行查看 历史
张一诺 提交于 2022-12-06 09:58 . 0.1.3
%define luaver 5.3
%define luapkgdir %{_datadir}/lua/%{luaver}
# LuaJIT is compatible with Lua 5.1 and uses the same directory for modules
%global ljpkgdir %{_datadir}/lua/5.1
Name: lua-fun
Version: 0.1.3
Release: 1%{?dist}
Summary: Functional programming library for Lua
Group: Development/Libraries
License: MIT
URL: https://github.com/rtsisyk/luafun
Source0: https://github.com/rtsisyk/luafun/archive/%{version}/luafun-%{version}.tar.gz
BuildArch: noarch
BuildRequires: luajit >= 2.0
BuildRequires: lua >= 5.1
Requires: lua >= 5.1
%package -n luajit-fun
Summary: Functional programming library for LuaJIT
Requires: luajit >= 2.0
%description -n lua-fun
Lua Fun is a high-performance functional programming library for Lua
designed with LuaJIT's trace compiler in mind.
Lua Fun provides a set of more than 50 programming primitives typically
found in languages like Standard ML, Haskell, Erlang, JavaScript, Python and
even Lisp. High-order functions such as map, filter, reduce, zip, etc.,
make it easy to write simple and efficient functional code.
This package provides a module for Lua %{luaver}.
%description -n luajit-fun
Lua Fun is a high-performance functional programming library for Lua
designed with LuaJIT's trace compiler in mind.
Lua Fun provides a set of more than 50 programming primitives typically
found in languages like Standard ML, Haskell, Erlang, JavaScript, Python and
even Lisp. High-order functions such as map, filter, reduce, zip, etc.,
make it easy to write simple and efficient functional code.
This package provides a module for LuaJIT.
%prep
%setup -q -n luafun-%{version}
%build
# nothing to do
%install
# Install for Lua
mkdir -p %{buildroot}%{luapkgdir}
cp -av fun.lua %{buildroot}%{luapkgdir}/fun.lua
# Install for LuaJIT
mkdir -p %{buildroot}%{ljpkgdir}
cp -av fun.lua %{buildroot}%{ljpkgdir}/fun.lua
%check
cd tests
luajit ./runtest *.lua
lua ./runtest *.lua
%files -n lua-fun
%{luapkgdir}/fun.lua
%doc README.md CONTRIBUTING.md
%license COPYING.md
%files -n luajit-fun
%{ljpkgdir}/fun.lua
%doc README.md CONTRIBUTING.md
%license COPYING.md
%changelog
* Mon Jan 18 2016 Roman Tsisyk <roman@tarantool.org> - 0.1.3-1
- Initial version.
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-oepkgs/lua-fun.git
git@gitee.com:src-oepkgs/lua-fun.git
src-oepkgs
lua-fun
lua-fun
master

搜索帮助

344bd9b3 5694891 D2dac590 5694891