6 Star 0 Fork 4

src-openEuler / java-ovirt-engine-sdk4

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
java-ovirt-engine-sdk4.spec 2.56 KB
一键复制 编辑 原始数据 按行查看 历史
woody2918 提交于 2024-01-29 02:35 . update java-ovirt-engine-sdk4.spec.
%global tar_version 4.4.6
Name: java-ovirt-engine-sdk4
Version: 4.4.6
Release: 1
Summary: Java SDK for version 4 of the oVirt Engine API
Group: Development/Languages
License: ASL 2.0
URL: http://ovirt.org/wiki/SDK
# This should be a tar file containing the generated source code of the
# SDK, as we can't build and run the generator with the packages
# available in the distribution:
Source0: https://resources.ovirt.org/pub/ovirt-4.4/src/java-ovirt-engine-sdk4/ovirt-engine-sdk-java-%{tar_version}.tar.gz
# This file is used to perform the build using Ant, because the upstream
# project has build dependencies that make it impossible to build it
# with the packages available in the distribution:
Source1: build.xml
# This file is used to transform the upstream 'pom.xml' file into a
# 'pom-nodeps.xml' file that doesn't have the dependencies of the
# code generator, as those aren't available in the distribution:
Source2: transform-pom.xsl
BuildArch: noarch
BuildRequires: ant
BuildRequires: javapackages-local
BuildRequires: zlib >= 1.2.11
BuildRequires: mvn(org.apache.httpcomponents:httpclient)
BuildRequires: mvn(org.apache.httpcomponents:httpcore)
BuildRequires: mvn(com.fasterxml.jackson.core:jackson-databind)
BuildRequires: mvn(com.fasterxml.jackson.core:jackson-core)
BuildRequires: mvn(com.fasterxml.jackson.core:jackson-annotations)
BuildRequires: mvn(org.slf4j:slf4j-api)
%description
This package contains the Java SDK for version 4 of the oVirt Engine
API.
%prep
# Extract the source:
%setup -q -n ovirt-engine-sdk-java-%{tar_version}
%build
# Copy the files required for the Ant build to the extracted SDK
# directory:
cp %{SOURCE1} %{SOURCE2} .
# Populate the lib directory with symlinks to the required dependencies that
# will be used to create the compiler classpath:
mkdir lib
while read jar
do
ln -s %{_javadir}/${jar}.jar lib
done << __EOF__
httpcomponents/httpclient
httpcomponents/httpcore
jackson/jackson-databind
jackson/jackson-core
jackson/jackson-annotations
slf4j/api
__EOF__
# Perform build using Ant:
java -jar %{_javadir}/ant-launcher.jar -f build.xml
%install
# Install the POM without dependencies created during the build process
# and the .jar file:
%mvn_artifact pom-nodeps.xml target/%{name}.jar
%mvn_install
%files -f .mfiles
%dir %{_javadir}/%{name}
%doc README.adoc
%license LICENSE.txt
%changelog
* Mon Jan 29 2024 woody2918 <wudi1@uniontech.com> - 4.4.6-1
- Update version to 4.4.6
* Fri Apr 1 2022 liqiuyu <liqiuyu@kylinos.cn> - 4.4.5-2
- Adding buildRequires
* Thu Jul 01 2021 wangdi <wangdi@kylinos.cn> - 4.4.5-1
- Init pacakage for version 4.4.5
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/java-ovirt-engine-sdk4.git
git@gitee.com:src-openeuler/java-ovirt-engine-sdk4.git
src-openeuler
java-ovirt-engine-sdk4
java-ovirt-engine-sdk4
master

搜索帮助

344bd9b3 5694891 D2dac590 5694891