代码拉取完成,页面将自动刷新
%global _empty_manifest_terminate_build 0
Name: python-wurlitzer
Version: 3.1.1
Release: 1
Summary: Capture C-level output in context managers
License: MIT
URL: https://github.com/minrk/wurlitzer
Source0: https://files.pythonhosted.org/packages/33/90/623f99c55c7d0727a58eb2b7dfb65cb406c561a5c2e9a95b0d6a450c473d/wurlitzer-3.1.1.tar.gz
BuildArch: noarch
%description
Capture C-level stdout/stderr pipes in Python via os.dup2.
%package -n python3-wurlitzer
Summary: Capture C-level output in context managers
Provides: python-wurlitzer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pytest
BuildRequires: python3-mock
BuildRequires: fdupes
%description -n python3-wurlitzer
Capture C-level stdout/stderr pipes in Python via os.dup2.
%package help
Summary: Development documents and examples for wurlitzer
Provides: python3-wurlitzer-doc
%description help
Capture C-level stdout/stderr pipes in Python via os.dup2.
%prep
%autosetup -n wurlitzer-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
pytest test.py
%files -n python3-wurlitzer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Aug 23 2024 zhaoshuang <zhaoshuang@uniontech.com> - 3.1.1-1
- Update package to version 3.1.1
- fix restore after capture with optimized file pipes
* Mon May 27 2024 zhaojingyu <zhaojingyu@kylinos.cn> - 3.1.0-1
- Update package to version 3.1.0
- accept fileno-having objects for GIL-less capture
* Fri Mar 17 2023 wubijie <wubijie@kylinos.cn> - 3.0.3-1
- Update package to version 3.0.3
* Sat Sep 24 2022 guozhengxin <guozhengxin@kylinos.cn> - 3.0.2-1
- Upgrade package to version 3.0.2
* Mon Jul 12 2021 duyiwei <duyiwei@kylinos.cn> - 2.1.0-1
- Init package.
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。